UiPath Orchestrator Guide

Software Requirements

Supported Software
Supported Versions

Windows Server

  • 2008 R2 SP1
  • 2012 R2
  • 2016
  • 2019

SQL Server

  • 2008 R2 Standard or Enterprise Edition
  • 2012 Standard or Enterprise Edition
  • 2014 Standard or Enterprise Edition
  • 2016 Standard or Enterprise Edition
  • 2017 Standard or Enterprise Edition

Virtualization Platforms

  • VMWare
  • Citrix XenDesktop - 7.6+
  • Oracle VirtualBox - 5.0+
  • Microsoft Hyper-V
  • other platforms that can create a Windows Virtual Machine

.NET Framework

  • minimum: 4.6.1

PowerShell

4.0+

WebDeploy

3.5+
64bit version

Please note that this is required only for PowerShell script installations, such as the Azure one.

Internet Information Services Manager (IIS)

7.5+

URL Rewrite

2.0+

ElasticSearch

2.3 - 6.x
Please note that support for versions 2.x of Elasticsearch has ended on their part.

Kibana

4.0 - 6.6.1

Redis Enterprise

5.2 - 5.4

Redis (on Linux) *

3.0.7 - 5.0.4

Google Chrome

50+

Internet Explorer *

11

Microsoft Edge

20+

* Redis on Windows (v3.0.504) is an available, but not recommended, option. It is built by MSOpenTech and has not been updated since July 2016. It is not supported by either Redis or RedisLabs.

Important! The Enterprise Mode needs to be turned off on Internet Explorer.

For more information on how to turn off that Internet Explorer feature, see this page.

Note:

ElasticSearch can be installed on any of the following operating systems:

You can also check out software requirements for Studio and Robot.



Software Requirements


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.